Back to overview
Degraded

Degraded Functionality

Jun 12 at 11:39am HDT
Affected services
Calico Cloud Portal

Resolved
Jun 12 at 12:28pm HDT

The earlier impact related to the ongoing Google Cloud Platform (GCP) incident has been mitigated. Calico Cloud operations—including cluster connect, upgrade, and delete—are now functioning normally.

At no point was network policy enforcement or cluster security affected.

We will continue to monitor for stability, but no further user action is required at this time. Thank you for your patience.

Created
Jun 12 at 11:39am HDT

We are currently experiencing degraded functionality due to an ongoing incident with Google Cloud Platform (GCP). As a result, some Calico Cloud operations—including connecting, upgrading, and deleting clusters—may be impacted.

Note: Core functionality such as network policy enforcement and cluster security remains unaffected and continues to operate as expected.